# CVE-2026-55565: Yamcs: Authenticated remote code execution via unescaped StreamSQL `LIKE` pattern compiled by Janino (`LikeExpression`)

> Authenticated attackers can execute arbitrary code on Yamcs servers by injecting Java code via unescaped SQL LIKE patterns.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-c64q-hj4j-375f

## What is CVE-2026-55565?

CVE-2026-55565 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs LikeExpression.fillCode_getValueReturn in yamcs-core/src/main/java/org/yamcs/yarch/streamsql/LikeExpression.java inserts an unescaped LIKE pattern into Java source compiled by Expression.getCompiledExpression through SimpleCompiler.cook instead of applying ValueExpression.escapeJavaString. The pattern can originate from POST /api/archive/{instance}:executeSql, POST /api/archive/{instance}:streamSql, POST /api/archive/{instance}/tables/{table}:readRows, GET /api/archive/{instance}/events, or activity searches, including paths available with ReadTables, ReadEvents, or ReadActivities. A quote in the pattern can inject Java that runs as the Yamcs server process. This issue is fixed in versions 5.12.8 and 5.13.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55565?

4 open source packages ship an affected version, including org.yamcs:yamcs-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |

## How do I fix CVE-2026-55565?

Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.

## Is CVE-2026-55565 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55565 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55565 and fix it if it is affected.

What it is: CVE-2026-55565 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55565 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55565/ (Markdown: https://insights.sbomify.com/CVE-2026-55565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55565
- OSV: https://osv.dev/vulnerability/CVE-2026-55565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55565/
Summaries are generated and may contain mistakes; the official description above is the record.
