CVE-2026-55568 Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext

Medium 5.9 Published Updated

Attackers can intercept cleartext proxy credentials and CONNECT targets when using older libcurl versions with HTTPS proxy configurations in Guzzle.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55568?

CVE-2026-55568 is a medium-severity vulnerability in guzzle, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.

Weakness: CWE-636, CWE-319, CWE-311

Which versions are affected by CVE-2026-55568?

2 open source packages ship an affected version, including guzzlehttp/guzzle. It affects 1 product.

PackageAffectedFixed in
guzzlehttp/guzzle PackagistAll versions7.12.1
guzzlehttp/guzzle PackagistAll versions7.12.1

Products include Guzzlephp Guzzle.

How do I fix CVE-2026-55568?

Upgrade guzzlehttp/guzzle to 7.12.1 or later.

Is CVE-2026-55568 being exploited?

There is no known exploitation of CVE-2026-55568 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-55568, GHSA-wpwq-4j6v-78m3, MINI-3mqr-qjrg-8jhq, MINI-873v-mgr7-c6xg, MINI-gqr9-3jwm-6j98, MINI-h2wg-xm94-jqrc and 6 more.

Is CVE-2026-55568 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free