{"answers":{"affected":"2 open source packages ship an affected version, including guzzlehttp/guzzle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-55568 in the wild and no public exploit code.","fix":"Upgrade guzzlehttp/guzzle to 7.12.1 or later.","what":"CVE-2026-55568 is a medium-severity vulnerability in guzzle, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55568 and fix it if it is affected.\n\nWhat it is: CVE-2026-55568 is a medium-severity vulnerability in guzzle, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55568 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.12.1\n- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.12.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55568/ (Markdown: https://insights.sbomify.com/CVE-2026-55568/index.md)","id":"CVE-2026-55568","markdown":"https://insights.sbomify.com/CVE-2026-55568/index.md","name":"CVE-2026-55568","record":{"aliases":["DEBIAN-CVE-2026-55568","GHSA-wpwq-4j6v-78m3","MINI-3mqr-qjrg-8jhq","MINI-873v-mgr7-c6xg","MINI-gqr9-3jwm-6j98","MINI-h2wg-xm94-jqrc","MINI-h9jx-77q4-qccp","MINI-m839-4f33-6g4w","MINI-mjqr-vrgf-rp44","MINI-p3w5-xqpv-86mq","MINI-pfq2-26pq-7vpg","UBUNTU-CVE-2026-55568"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP HTTP client","requires_auth":"none","summary":"Attackers can intercept cleartext proxy credentials and CONNECT targets when using older libcurl versions with HTTPS proxy configurations in Guzzle.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"guzzle","vendor":"guzzlephp"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-636","name":"Not Failing Securely"},{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\\Handler\\CurlHandler and GuzzleHttp\\Handler\\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext","id":"CVE-2026-55568","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"aqua: Archive extraction in aqua follows attacker-planted symlinks, allowing writes outside the install directory","id":"CVE-2026-55569"},"packages":[{"ecosystem":"Packagist","fixed":["7.12.1"],"introduced":["0"],"last_affected":[],"package":"guzzlehttp/guzzle","purl":null,"source":"GHSA-wpwq-4j6v-78m3"},{"ecosystem":"Packagist","fixed":["7.12.1"],"introduced":["0"],"last_affected":[],"package":"guzzlehttp/guzzle","purl":"pkg:composer/guzzlehttp/guzzle","source":"GHSA-wpwq-4j6v-78m3"}],"prev":{"headline":"BleachBit: Exploit File Delete to Escalate Privilege","id":"CVE-2026-55567"},"products":["guzzle"],"published":"2026-06-23","related":[{"cvss_score":5.8,"headline":"Guzzle: Dot-Only Cookie Domains Match All Hosts in guzzlehttp/guzzle","id":"CVE-2026-55767","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":4.7,"headline":"Guzzle: Cookie Disclosure and Injection via IP-Address Domains","id":"CVE-2026-59883","kev_date_added":null,"published":"2026-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["guzzle"]},"summary":"Attackers can intercept cleartext proxy credentials and CONNECT targets when using older libcurl versions with HTTPS proxy configurations in Guzzle.","url":"https://insights.sbomify.com/CVE-2026-55568/"}