# CVE-2026-55568: Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext

> Attackers can intercept cleartext proxy credentials and CONNECT targets when using older libcurl versions with HTTPS proxy configurations in Guzzle.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-55568, GHSA-wpwq-4j6v-78m3, MINI-3mqr-qjrg-8jhq, MINI-873v-mgr7-c6xg, MINI-gqr9-3jwm-6j98, MINI-h2wg-xm94-jqrc, MINI-h9jx-77q4-qccp, MINI-m839-4f33-6g4w, MINI-mjqr-vrgf-rp44, MINI-p3w5-xqpv-86mq, MINI-pfq2-26pq-7vpg, UBUNTU-CVE-2026-55568

## What is CVE-2026-55568?

CVE-2026-55568 is a medium-severity vulnerability in guzzle, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.

Weakness: CWE-636 (Not Failing Securely), CWE-319 (Cleartext Transmission of Sensitive Information), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2026-55568?

2 open source packages ship an affected version, including guzzlehttp/guzzle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.12.1 |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.12.1 |

Products: Guzzlephp Guzzle.

## How do I fix CVE-2026-55568?

Upgrade guzzlehttp/guzzle to 7.12.1 or later.

## Is CVE-2026-55568 being exploited?

There is no known exploitation of CVE-2026-55568 in the wild and no public exploit code.

## Other vulnerabilities in guzzle

- [CVE-2026-55767](https://insights.sbomify.com/CVE-2026-55767/): Guzzle: Dot-Only Cookie Domains Match All Hosts in guzzlehttp/guzzle (medium 5.8)
- [CVE-2026-59883](https://insights.sbomify.com/CVE-2026-59883/): Guzzle: Cookie Disclosure and Injection via IP-Address Domains (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55568 and fix it if it is affected.

What it is: CVE-2026-55568 is a medium-severity vulnerability in guzzle, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55568 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.12.1
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55568/ (Markdown: https://insights.sbomify.com/CVE-2026-55568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55568
- OSV: https://osv.dev/vulnerability/CVE-2026-55568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55568/
Summaries are generated and may contain mistakes; the official description above is the record.
