# CVE-2026-55570: Cross-site scripting in siyuan

> Attackers can execute arbitrary OS commands via stored XSS in the SiYuan marketplace due to unescaped attributes in the desktop client.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-x88j-wgpr-h22x

## What is CVE-2026-55570?

CVE-2026-55570 is a critical cross-site scripting vulnerability in siyuan-note siyuan, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SiYuan is an open-source personal knowledge management system. Prior to 3.7.0, it does not escape the untrusted fields (name, version, author, description) when they are serialized into the data-obj HTML attribute of each marketplace card. Because the attribute is single-quoted and the value is produced with JSON.stringify() (which does not escape ', <, or >), a package whose name contains a single quote breaks out of the attribute and injects arbitrary HTML. In the desktop client the main BrowserWindow runs with nodeIntegration: true, contextIsolation: false, so the injected markup escalates from DOM XSS to arbitrary OS command execution. This is the same root cause and same impact as the original advisory, reached through a sibling sink the patch did not cover.  This vulnerability is fixed in 3.7.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-55570?


## How do I fix CVE-2026-55570?

No fix has been published for CVE-2026-55570 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55570 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55570 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55570 and fix it if it is affected.

What it is: CVE-2026-55570 is a critical cross-site scripting vulnerability in siyuan-note siyuan, published on 24 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55570 exists.

Affected product: siyuan-note siyuan. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55570/ (Markdown: https://insights.sbomify.com/CVE-2026-55570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55570
- OSV: https://osv.dev/vulnerability/CVE-2026-55570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55570/
Summaries are generated and may contain mistakes; the official description above is the record.
