{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55573 exists.","fix":"No fix has been published for CVE-2026-55573 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-55573 is a critical unsafe deserialization vulnerability in e107inc e107, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55573 and fix it if it is affected.\n\nWhat it is: CVE-2026-55573 is a critical unsafe deserialization vulnerability in e107inc e107, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55573 exists.\n\nAffected product: e107inc e107. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55573/ (Markdown: https://insights.sbomify.com/CVE-2026-55573/index.md)","id":"CVE-2026-55573","markdown":"https://insights.sbomify.com/CVE-2026-55573/index.md","name":"CVE-2026-55573","record":{"aliases":["GHSA-c8h6-wpj3-4cr8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"e107 CMS","requires_auth":"none","summary":"Unauthenticated attackers can achieve remote code execution on e107 CMS servers by exploiting unsafe deserialization in the installer script.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\\Psr7\\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"e107: Unsafe deserialization in install.php allows unauthenticated RCE via POP chain","id":"CVE-2026-55573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"vLLM: ReDoS via structured_outputs.regex compiled without timeout in xgrammar and outlines backends","id":"CVE-2026-55574"},"packages":[],"prev":{"headline":"e107: SQL injection in alt_auth plugin (otherdb / e107db backends) via login username","id":"CVE-2026-55572"},"products":["e107"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["e107inc"]},"summary":"Unauthenticated attackers can achieve remote code execution on e107 CMS servers by exploiting unsafe deserialization in the installer script.","url":"https://insights.sbomify.com/CVE-2026-55573/"}