# CVE-2026-55575: LiquidJS: `pop` filter bypasses `memoryLimit` accounting that its array-filter siblings enforce

> Attackers can cause denial of service in LiquidJS by using the pop filter to bypass memory limits, leading to excessive resource consumption.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-g357-x5c3-c72p, MINI-5pp5-2rr8-ghvq, MINI-7gfh-9r6g-92r4, MINI-j8w3-g69w-4whc

## What is CVE-2026-55575?

CVE-2026-55575 is a high-severity denial of service vulnerability in harttle liquidjs, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiquidJS is a Shopify / GitHub Pages compatible template engine in pure JavaScript. Prior to 10.27.1, the pop array filter at src/filters/array.ts allocated a full clone of its input array via [...toArray(v)] without calling this.context.memoryLimit.use(...), allowing a template render such as {{ huge_array | pop }} to allocate an O(N) clone of an attacker-influenced array outside the configured memoryLimit budget. This issue is fixed in version 10.27.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-55575?

2 open source packages ship an affected version, including liquidjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `liquidjs` | npm | All versions | 10.27.1 |
| `liquidjs` | npm | All versions | 10.27.1 |

## How do I fix CVE-2026-55575?

Upgrade liquidjs to 10.27.1 or later.

## Is CVE-2026-55575 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55575 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55575 and fix it if it is affected.

What it is: CVE-2026-55575 is a high-severity denial of service vulnerability in harttle liquidjs, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55575 exists.

Affected packages and fixed versions:
- liquidjs (npm): affected all versions; fixed in 10.27.1
- liquidjs (npm): affected all versions; fixed in 10.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55575/ (Markdown: https://insights.sbomify.com/CVE-2026-55575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55575
- OSV: https://osv.dev/vulnerability/CVE-2026-55575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55575/
Summaries are generated and may contain mistakes; the official description above is the record.
