{"answers":{"affected":"2 open source packages ship an affected version, including pheditor/pheditor.","exploited":"There is no known exploitation of CVE-2026-55578 in the wild and no public exploit code.","fix":"Upgrade pheditor/pheditor to 2.0.6 or later.","what":"CVE-2026-55578 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55578 and fix it if it is affected.\n\nWhat it is: CVE-2026-55578 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55578 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6\n- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55578/ (Markdown: https://insights.sbomify.com/CVE-2026-55578/index.md)","id":"CVE-2026-55578","markdown":"https://insights.sbomify.com/CVE-2026-55578/index.md","name":"CVE-2026-55578","record":{"aliases":["GHSA-wg4w-wr5q-6vjc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Pheditor file manager","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary OS commands via the terminal feature due to incomplete input sanitization, allowing remote code execution.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Pheditor is a single-file editor and file manager written in PHP. From version 2.0.1 to before version 2.0.6, the terminal feature in Pheditor uses an incomplete character blocklist to sanitize user-supplied commands before passing them to shell_exec(). After the fix for GHSA-9643-6xjp-vx57 (which added $ to the blocklist), the characters | (single pipe), ` (backtick), and the newline byte (0x0A) remain unblocked. An authenticated user with the terminal permission (enabled by default) can leverage any of these to bypass the TERMINAL_COMMANDS allowlist and execute arbitrary OS commands as the web server user. This issue has been patched in version 2.0.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pheditor: Incomplete command sanitization in terminal feature allows RCE via pipe operator, backtick substitution, and newline injection","id":"CVE-2026-55578","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Pheditor: Hardcoded default password 'admin' with no forced change enables full application compromise","id":"CVE-2026-55579"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.6"],"introduced":["2.0.1"],"last_affected":[],"package":"pheditor/pheditor","purl":null,"source":"GHSA-wg4w-wr5q-6vjc"},{"ecosystem":"Packagist","fixed":["2.0.6"],"introduced":["2.0.1"],"last_affected":[],"package":"pheditor/pheditor","purl":"pkg:composer/pheditor/pheditor","source":"GHSA-wg4w-wr5q-6vjc"}],"prev":{"headline":"ImageMagick: Heap Buffer Overflow in ImageMagick MVG decoder","id":"CVE-2026-55577"},"products":["pheditor"],"published":"2026-07-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["pheditor"]},"summary":"Authenticated users can execute arbitrary OS commands via the terminal feature due to incomplete input sanitization, allowing remote code execution.","url":"https://insights.sbomify.com/CVE-2026-55578/"}