# CVE-2026-55578: Pheditor: Incomplete command sanitization in terminal feature allows RCE via pipe operator, backtick substitution, and newline injection

> Authenticated users can execute arbitrary OS commands via the terminal feature due to incomplete input sanitization, allowing remote code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-wg4w-wr5q-6vjc

## What is CVE-2026-55578?

CVE-2026-55578 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pheditor is a single-file editor and file manager written in PHP. From version 2.0.1 to before version 2.0.6, the terminal feature in Pheditor uses an incomplete character blocklist to sanitize user-supplied commands before passing them to shell_exec(). After the fix for GHSA-9643-6xjp-vx57 (which added $ to the blocklist), the characters | (single pipe), ` (backtick), and the newline byte (0x0A) remain unblocked. An authenticated user with the terminal permission (enabled by default) can leverage any of these to bypass the TERMINAL_COMMANDS allowlist and execute arbitrary OS commands as the web server user. This issue has been patched in version 2.0.6.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55578?

2 open source packages ship an affected version, including pheditor/pheditor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.6 |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.6 |

## How do I fix CVE-2026-55578?

Upgrade pheditor/pheditor to 2.0.6 or later.

## Is CVE-2026-55578 being exploited?

There is no known exploitation of CVE-2026-55578 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55578 and fix it if it is affected.

What it is: CVE-2026-55578 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55578 in the wild and no public exploit code.

Affected packages and fixed versions:
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55578/ (Markdown: https://insights.sbomify.com/CVE-2026-55578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55578
- OSV: https://osv.dev/vulnerability/CVE-2026-55578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55578/
Summaries are generated and may contain mistakes; the official description above is the record.
