# CVE-2026-55579: Pheditor: Hardcoded default password 'admin' with no forced change enables full application compromise

> Pheditor uses a hardcoded default password allowing attackers to gain full access to file management and execute remote code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-p4h7-p9rj-2pq2

## What is CVE-2026-55579?

CVE-2026-55579 is a critical vulnerability in pheditor, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pheditor is a single-file editor and file manager written in PHP. From version 2.0.1 to before version 2.0.6, Pheditor ships with a hardcoded default password admin (SHA-512 hash stored at pheditor.php:11). There is no mechanism to force a password change on first login. Any deployment using the default credentials grants an attacker full access to the file editor, file upload, and terminal features, enabling arbitrary file read/write and remote code execution. This issue has been patched in version 2.0.6.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-55579?

2 open source packages ship an affected version, including pheditor/pheditor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.6 |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.6 |

## How do I fix CVE-2026-55579?

Upgrade pheditor/pheditor to 2.0.6 or later.

## Is CVE-2026-55579 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55579 exists.

Public exploit code:

- CVE-2026-55579 – Unauthenticated RCE in Pheditor via hardcoded default password "admin". Full Python exploit with file upload & terminal execution. No dependencies. (github_poc): https://github.com/Ch4120N/CVE-2026-55579

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55579 and fix it if it is affected.

What it is: CVE-2026-55579 is a critical vulnerability in pheditor, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55579 exists.

Affected packages and fixed versions:
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55579/ (Markdown: https://insights.sbomify.com/CVE-2026-55579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55579
- OSV: https://osv.dev/vulnerability/CVE-2026-55579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55579/
Summaries are generated and may contain mistakes; the official description above is the record.
