{"answers":{"affected":"2 open source packages ship an affected version, including phpsysinfo/phpsysinfo.","exploited":"There is no known exploitation of CVE-2026-55584 in the wild and no public exploit code.","fix":"Upgrade phpsysinfo/phpsysinfo to 3.4.6 or later.","what":"CVE-2026-55584 is a high-severity authentication bypass vulnerability in phpsysinfo, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55584 and fix it if it is affected.\n\nWhat it is: CVE-2026-55584 is a high-severity authentication bypass vulnerability in phpsysinfo, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55584 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpsysinfo/phpsysinfo (Packagist): affected all versions; fixed in 3.4.6\n- phpsysinfo/phpsysinfo (Packagist): affected all versions; fixed in 3.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55584/ (Markdown: https://insights.sbomify.com/CVE-2026-55584/index.md)","id":"CVE-2026-55584","markdown":"https://insights.sbomify.com/CVE-2026-55584/index.md","name":"CVE-2026-55584","record":{"aliases":["DEBIAN-CVE-2026-55584","GHSA-786w-p5pm-cvgh","UBUNTU-CVE-2026-55584"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpSysInfo system monitor","requires_auth":"none","summary":"Remote attackers can bypass IP allowlists by spoofing headers to access sensitive system information in phpSysInfo.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"phpSysInfo is a customizable PHP script that displays system information. Prior to 3.4.6, the PSI_ALLOWED access-control check in read_config.php trusts attacker-controlled X-Forwarded-For and Client-IP HTTP headers before REMOTE_ADDR. A remote unauthenticated attacker can supply an allowed address in one of these headers to impersonate a trusted client and access exposed hostname, kernel, CPU, memory, filesystem, and network-interface information. This issue is fixed in version 3.4.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2026-06-25","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-25T18:29:12Z","kind":"github_poc","ref":"https://github.com/mirackayikci/CVE-2026-55584","stars":0,"title":"CVE-2026-55584 — phpSysInfo IP Allowlist Bypass"},{"date":"2026-08-17","kind":"exploitdb","ref":"52648","stars":null,"title":"phpSysInfo 3.4.5 - IP Allowlist Bypass"}],"tier":"poc_unverified"},"has_fix":true,"headline":"phpSysInfo: IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers","id":"CVE-2026-55584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"QWED: Authenticated Remote Code Execution via Unsafe SymPy `parse_expr()`","id":"CVE-2026-55585"},"packages":[{"ecosystem":"Packagist","fixed":["3.4.6"],"introduced":["0"],"last_affected":[],"package":"phpsysinfo/phpsysinfo","purl":null,"source":"GHSA-786w-p5pm-cvgh"},{"ecosystem":"Packagist","fixed":["3.4.6"],"introduced":["0"],"last_affected":[],"package":"phpsysinfo/phpsysinfo","purl":"pkg:composer/phpsysinfo/phpsysinfo","source":"GHSA-786w-p5pm-cvgh"}],"prev":{"headline":"Twenty: Cross-workspace IDOR in AgentTurnResolver","id":"CVE-2026-55583"},"products":["phpsysinfo"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["phpsysinfo"]},"summary":"Remote attackers can bypass IP allowlists by spoofing headers to access sensitive system information in phpSysInfo.","url":"https://insights.sbomify.com/CVE-2026-55584/"}