# CVE-2026-55584: phpSysInfo: IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers

> Remote attackers can bypass IP allowlists by spoofing headers to access sensitive system information in phpSysInfo.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-55584, GHSA-786w-p5pm-cvgh, UBUNTU-CVE-2026-55584

## What is CVE-2026-55584?

CVE-2026-55584 is a high-severity authentication bypass vulnerability in phpsysinfo, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpSysInfo is a customizable PHP script that displays system information. Prior to 3.4.6, the PSI_ALLOWED access-control check in read_config.php trusts attacker-controlled X-Forwarded-For and Client-IP HTTP headers before REMOTE_ADDR. A remote unauthenticated attacker can supply an allowed address in one of these headers to impersonate a trusted client and access exposed hostname, kernel, CPU, memory, filesystem, and network-interface information. This issue is fixed in version 3.4.6.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-55584?

2 open source packages ship an affected version, including phpsysinfo/phpsysinfo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpsysinfo/phpsysinfo` | Packagist | All versions | 3.4.6 |
| `phpsysinfo/phpsysinfo` | Packagist | All versions | 3.4.6 |

## How do I fix CVE-2026-55584?

Upgrade phpsysinfo/phpsysinfo to 3.4.6 or later.

## Is CVE-2026-55584 being exploited?

There is no known exploitation of CVE-2026-55584 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-55584 — phpSysInfo IP Allowlist Bypass (github_poc): https://github.com/mirackayikci/CVE-2026-55584
- phpSysInfo 3.4.5 - IP Allowlist Bypass (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55584 and fix it if it is affected.

What it is: CVE-2026-55584 is a high-severity authentication bypass vulnerability in phpsysinfo, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55584 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpsysinfo/phpsysinfo (Packagist): affected all versions; fixed in 3.4.6
- phpsysinfo/phpsysinfo (Packagist): affected all versions; fixed in 3.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55584/ (Markdown: https://insights.sbomify.com/CVE-2026-55584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55584
- OSV: https://osv.dev/vulnerability/CVE-2026-55584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55584/
Summaries are generated and may contain mistakes; the official description above is the record.
