# CVE-2026-55585: QWED: Authenticated Remote Code Execution via Unsafe SymPy `parse_expr()`

> Authenticated attackers can execute arbitrary Python code via unsafe SymPy expression parsing in QWED, leading to full system compromise.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-q27q-98j4-9pfv, PYSEC-2026-3914

## What is CVE-2026-55585?

CVE-2026-55585 is a high-severity code injection vulnerability in QWED-AI qwed-verification, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

QWED is open-source AI verification infrastructure for deterministic verification of LLM outputs, tool calls, code, schemas, and agent state before production execution. Prior to 5.1.2, the qwed package passes caller-controlled math expressions directly to SymPy parse_expr() without restricted global_dict and local_dict namespaces, allowing Python eval() to resolve builtins and execute arbitrary Python code in the API server process. In src/qwed_new/api/main.py, POST /verify/math is protected by get_current_tenant but accepts any valid tenant API key, reads the expression field, applies only a cosmetic re.sub(r'(\d)(()', r'\1*\2', expression) normalization, and passes the result to parse_expr(). In src/qwed_new/core/batch.py, POST /verify/batch sends math items through batch_service.create_job(), stores item.query verbatim, and _verify_item() passes VerificationType.MATH input to parse_expr() without sanitization. The default-enabled POST /auth/signup endpoint allows anyone to create a standard tenant account, POST /auth/api-keys issues an x-api-key, and either vulnerable path can then be used to read or write files, modify data, execute operating system commands, terminate the service, and compromise other tenants in a shared deployment. This issue is fixed in version 5.1.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55585?

3 open source packages ship an affected version, including qwed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qwed` | PyPI | All versions | 5.1.2 |
| `qwed` | PyPI | All versions | 5.1.2 |
| `qwed` | PyPI | All versions | 5.1.2 |

## How do I fix CVE-2026-55585?

Upgrade qwed to 5.1.2 or later.

## Is CVE-2026-55585 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55585 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55585 and fix it if it is affected.

What it is: CVE-2026-55585 is a high-severity code injection vulnerability in QWED-AI qwed-verification, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55585 exists.

Affected packages and fixed versions:
- qwed (PyPI): affected all versions; fixed in 5.1.2
- qwed (PyPI): affected all versions; fixed in 5.1.2
- qwed (PyPI): affected all versions; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55585/ (Markdown: https://insights.sbomify.com/CVE-2026-55585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55585
- OSV: https://osv.dev/vulnerability/CVE-2026-55585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55585/
Summaries are generated and may contain mistakes; the official description above is the record.
