# CVE-2026-55590: CakePHP: Open redirect weakness via backslash bypass

> Attackers can bypass redirect validation to send users to malicious sites via the login redirect parameter in the CakePHP authentication plugin.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-hhpq-7wg4-36jm

## What is CVE-2026-55590?

CVE-2026-55590 is a medium-severity vulnerability in cakephp authentication, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CakePHP Authentication is an authentication plugin for CakePHP that can also be used in PSR-7 based applications. Prior to 2.11.1, 3.3.6, and 4.1.1, the getLoginRedirect() method contains a weakness to backslash bypasses that allows redirect targets with attacker-controlled hostnames through the redirect query string parameter. This issue is fixed in versions 2.11.1, 3.3.6, and 4.1.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-55590?

6 open source packages ship an affected version, including cakephp/authentication. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/authentication` | Packagist | All versions | 2.11.1 |
| `cakephp/authentication` | Packagist | All versions | 2.11.1 |
| `cakephp/authentication` | Packagist | From 3.0.0 | 3.3.6 |
| `cakephp/authentication` | Packagist | From 3.0.0 | 3.3.6 |
| `cakephp/authentication` | Packagist | From 4.0.0 | 4.1.1 |
| `cakephp/authentication` | Packagist | From 4.0.0 | 4.1.1 |

Products: Cakephp Cakephp.

## How do I fix CVE-2026-55590?

Upgrade cakephp/authentication to a fixed version for your release line: 2.11.1, 3.3.6 or 4.1.1.

## Is CVE-2026-55590 being exploited?

There is no known exploitation of CVE-2026-55590 in the wild and no public exploit code.

## Other vulnerabilities in cakephp authentication

- [CVE-2023-22727](https://insights.sbomify.com/CVE-2023-22727/): Database Query::offset() and limit() vulnerable to SQL injection in cakephp (critical 9.8)
- [CVE-2020-35239](https://insights.sbomify.com/CVE-2020-35239/): CakePHP allows method override parameters to bypass CSRF checks (high 8.8)
- [CVE-2015-8379](https://insights.sbomify.com/CVE-2015-8379/): CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter (high 8.8)
- [CVE-2019-11458](https://insights.sbomify.com/CVE-2019-11458/): Unsafe deserialization in SmtpTransport in CakePHP (high 7.5)
- [CVE-2016-4793](https://insights.sbomify.com/CVE-2016-4793/): CakePHP allows remote attackers to spoof their IP (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55590 and fix it if it is affected.

What it is: CVE-2026-55590 is a medium-severity vulnerability in cakephp authentication, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55590 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/authentication (Packagist): affected all versions; fixed in 2.11.1
- cakephp/authentication (Packagist): affected all versions; fixed in 2.11.1
- cakephp/authentication (Packagist): affected from 3.0.0; fixed in 3.3.6
- cakephp/authentication (Packagist): affected from 3.0.0; fixed in 3.3.6
- cakephp/authentication (Packagist): affected from 4.0.0; fixed in 4.1.1
- cakephp/authentication (Packagist): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55590/ (Markdown: https://insights.sbomify.com/CVE-2026-55590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55590
- OSV: https://osv.dev/vulnerability/CVE-2026-55590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55590/
Summaries are generated and may contain mistakes; the official description above is the record.
