# CVE-2026-55593: Froxlor: CSRF Vulnerability in Froxlor AJAX Endpoint — Missing Cross-Site Request Forgery Protection

> An attacker can trick an administrator into modifying API key restrictions via a forged request, bypassing security controls in Froxlor.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-xpr4-8vp6-c87j

## What is CVE-2026-55593?

CVE-2026-55593 is a medium-severity vulnerability in froxlor, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Froxlor is open source server administration software. Prior to 2.3.8, the standalone lib/ajax.php entry point bypasses the centralized request validation in lib/init.php, and Ajax::handle in lib/Froxlor/Ajax/Ajax.php checks only for a valid session before routing state-changing requests. The editapikey action in Ajax::editApiKey updates allowed_from and valid_until without validating a CSRF token, while templates/Froxlor/assets/js/jquery/apikeys.js sends no token because the endpoint does not require one. An unauthenticated attacker can induce an authenticated administrator's browser to submit a forged request that adds an attacker-controlled address to an API key's allowed_from list or removes its expiration, weakening the key's security restrictions. This issue is fixed in version 2.3.8.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-55593?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |

## How do I fix CVE-2026-55593?

Upgrade froxlor/froxlor to 2.3.8 or later.

## Is CVE-2026-55593 being exploited?

There is no known exploitation of CVE-2026-55593 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55593 and fix it if it is affected.

What it is: CVE-2026-55593 is a medium-severity vulnerability in froxlor, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55593 in the wild and no public exploit code.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55593/ (Markdown: https://insights.sbomify.com/CVE-2026-55593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55593
- OSV: https://osv.dev/vulnerability/CVE-2026-55593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55593/
Summaries are generated and may contain mistakes; the official description above is the record.
