# CVE-2026-55596: Plate: Media embed provider metadata can bypass URL sanitization and execute iframe JavaScript

> Attackers can execute arbitrary JavaScript in victims' browsers by crafting documents that bypass URL sanitization in the media embed renderer.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-qj6x-xx2h-8hvv

## What is CVE-2026-55596?

CVE-2026-55596 is a high-severity cross-site scripting vulnerability in udecode plate, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Plate is a rich-text editor with AI and shadcn/ui. From 53.0.0 until 53.1.4, the media embed renderer trusts serialized provider or sourceUrl metadata in useMediaState and skips parseMediaUrl protocol validation, allowing a crafted Plate document to set a known video provider while keeping url as a javascript: iframe source that the registry MediaEmbedElement renders directly as an iframe src when a victim opens the document. This issue is fixed in version 53.1.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55596?

2 open source packages ship an affected version, including @platejs/media.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@platejs/media` | npm | From 53.0.0 | 53.1.4 |
| `@platejs/media` | npm | From 53.0.0 | 53.1.4 |

## How do I fix CVE-2026-55596?

Upgrade @platejs/media to 53.1.4 or later.

## Is CVE-2026-55596 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55596 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55596 and fix it if it is affected.

What it is: CVE-2026-55596 is a high-severity cross-site scripting vulnerability in udecode plate, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55596 exists.

Affected packages and fixed versions:
- @platejs/media (npm): affected from 53.0.0; fixed in 53.1.4
- @platejs/media (npm): affected from 53.0.0; fixed in 53.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55596/ (Markdown: https://insights.sbomify.com/CVE-2026-55596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55596
- OSV: https://osv.dev/vulnerability/CVE-2026-55596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55596/
Summaries are generated and may contain mistakes; the official description above is the record.
