{"answers":{"affected":"2 open source packages ship an affected version, including @arikusi/deepseek-mcp-server.","exploited":"There is no known exploitation of CVE-2026-55604 in the wild and no public exploit code.","fix":"Upgrade @arikusi/deepseek-mcp-server to 1.7.0 or later.","what":"CVE-2026-55604 is a high-severity authentication bypass vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55604 and fix it if it is affected.\n\nWhat it is: CVE-2026-55604 is a high-severity authentication bypass vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55604 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.7.0\n- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55604/ (Markdown: https://insights.sbomify.com/CVE-2026-55604/index.md)","id":"CVE-2026-55604","markdown":"https://insights.sbomify.com/CVE-2026-55604/index.md","name":"CVE-2026-55604","record":{"aliases":["GHSA-fh3r-g96v-f578"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DeepSeek MCP Server","requires_auth":"none","summary":"Attackers can hijack user sessions by guessing session IDs to read and modify conversation context in DeepSeek MCP Server.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key","id":"CVE-2026-55604","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@arikusi/deepseek-mcp-server Missing Authentication on Self-Hosted HTTP MCP Endpoint","id":"CVE-2026-55605"},"packages":[{"ecosystem":"npm","fixed":["1.7.0"],"introduced":["1.4.2"],"last_affected":[],"package":"@arikusi/deepseek-mcp-server","purl":null,"source":"GHSA-fh3r-g96v-f578"},{"ecosystem":"npm","fixed":["1.7.0"],"introduced":["1.4.2"],"last_affected":[],"package":"@arikusi/deepseek-mcp-server","purl":"pkg:npm/%40arikusi/deepseek-mcp-server","source":"GHSA-fh3r-g96v-f578"}],"prev":{"headline":"http-proxy-middleware: multipart/form-data field injection via unescaped CRLF in `fixRequestBody`","id":"CVE-2026-55603"},"products":["deepseek-mcp-server"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["arikusi"]},"summary":"Attackers can hijack user sessions by guessing session IDs to read and modify conversation context in DeepSeek MCP Server.","url":"https://insights.sbomify.com/CVE-2026-55604/"}