# CVE-2026-55604: @arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key

> Attackers can hijack user sessions by guessing session IDs to read and modify conversation context in DeepSeek MCP Server.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-fh3r-g96v-f578

## What is CVE-2026-55604?

CVE-2026-55604 is a high-severity authentication bypass vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-55604?

2 open source packages ship an affected version, including @arikusi/deepseek-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@arikusi/deepseek-mcp-server` | npm | From 1.4.2 | 1.7.0 |
| `@arikusi/deepseek-mcp-server` | npm | From 1.4.2 | 1.7.0 |

## How do I fix CVE-2026-55604?

Upgrade @arikusi/deepseek-mcp-server to 1.7.0 or later.

## Is CVE-2026-55604 being exploited?

There is no known exploitation of CVE-2026-55604 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55604 and fix it if it is affected.

What it is: CVE-2026-55604 is a high-severity authentication bypass vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55604 in the wild and no public exploit code.

Affected packages and fixed versions:
- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.7.0
- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55604/ (Markdown: https://insights.sbomify.com/CVE-2026-55604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55604
- OSV: https://osv.dev/vulnerability/CVE-2026-55604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55604/
Summaries are generated and may contain mistakes; the official description above is the record.
