{"answers":{"affected":"2 open source packages ship an affected version, including @arikusi/deepseek-mcp-server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55605 exists.","fix":"Upgrade @arikusi/deepseek-mcp-server to 1.8.0 or later.","what":"CVE-2026-55605 is a medium-severity missing authorization vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55605 and fix it if it is affected.\n\nWhat it is: CVE-2026-55605 is a medium-severity missing authorization vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55605 exists.\n\nAffected packages and fixed versions:\n- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.8.0\n- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55605/ (Markdown: https://insights.sbomify.com/CVE-2026-55605/index.md)","id":"CVE-2026-55605","markdown":"https://insights.sbomify.com/CVE-2026-55605/index.md","name":"CVE-2026-55605","record":{"aliases":["GHSA-72f3-6w86-7rv3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DeepSeek MCP server","requires_auth":"none","summary":"Unauthenticated attackers can access the self-hosted HTTP endpoint to enumerate tools and invoke functions, potentially exposing API keys or executing actions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.8.0, the self-hosted HTTP transport of `@arikusi/deepseek-mcp-server` exposes `POST /mcp` without any authentication: `createMcpExpressApp` is called without an `authProvider` and no middleware guards the route, so any network-reachable client can issue an unauthenticated `initialize` request and obtain a valid MCP session identifier. In reproduced testing against commit `5e1302171e99`, an unauthenticated client was able to initialize a session, enumerate tools, and invoke the local `deepseek_sessions` tool with no credentials. The same unauthenticated session also exposes `deepseek_chat`, whose handler uses the server-side `DEEPSEEK_API_KEY` when self-hosted deployments configure one. This issue applies to self-hosted HTTP mode, not the separately documented hosted BYOK endpoint in `README.md`, which expects an `Authorization: Bearer ...` header. Upstream self-hosted container assets enable HTTP mode by default (`Dockerfile`) and publish port `3000` (`docker-compose.yml`). Version 1.8.0 contains a patch for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@arikusi/deepseek-mcp-server Missing Authentication on Self-Hosted HTTP MCP Endpoint","id":"CVE-2026-55605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"odhcpd: Stack buffer overread via DUID length endianness mismatch in memcmp()","id":"CVE-2026-55606"},"packages":[{"ecosystem":"npm","fixed":["1.8.0"],"introduced":["1.4.2"],"last_affected":[],"package":"@arikusi/deepseek-mcp-server","purl":null,"source":"GHSA-72f3-6w86-7rv3"},{"ecosystem":"npm","fixed":["1.8.0"],"introduced":["1.4.2"],"last_affected":[],"package":"@arikusi/deepseek-mcp-server","purl":"pkg:npm/%40arikusi/deepseek-mcp-server","source":"GHSA-72f3-6w86-7rv3"}],"prev":{"headline":"@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key","id":"CVE-2026-55604"},"products":["deepseek-mcp-server"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["arikusi"]},"summary":"Unauthenticated attackers can access the self-hosted HTTP endpoint to enumerate tools and invoke functions, potentially exposing API keys or executing actions.","url":"https://insights.sbomify.com/CVE-2026-55605/"}