# CVE-2026-55605: @arikusi/deepseek-mcp-server Missing Authentication on Self-Hosted HTTP MCP Endpoint

> Unauthenticated attackers can access the self-hosted HTTP endpoint to enumerate tools and invoke functions, potentially exposing API keys or executing actions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-72f3-6w86-7rv3

## What is CVE-2026-55605?

CVE-2026-55605 is a medium-severity missing authorization vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.8.0, the self-hosted HTTP transport of `@arikusi/deepseek-mcp-server` exposes `POST /mcp` without any authentication: `createMcpExpressApp` is called without an `authProvider` and no middleware guards the route, so any network-reachable client can issue an unauthenticated `initialize` request and obtain a valid MCP session identifier. In reproduced testing against commit `5e1302171e99`, an unauthenticated client was able to initialize a session, enumerate tools, and invoke the local `deepseek_sessions` tool with no credentials. The same unauthenticated session also exposes `deepseek_chat`, whose handler uses the server-side `DEEPSEEK_API_KEY` when self-hosted deployments configure one. This issue applies to self-hosted HTTP mode, not the separately documented hosted BYOK endpoint in `README.md`, which expects an `Authorization: Bearer ...` header. Upstream self-hosted container assets enable HTTP mode by default (`Dockerfile`) and publish port `3000` (`docker-compose.yml`). Version 1.8.0 contains a patch for this issue.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-55605?

2 open source packages ship an affected version, including @arikusi/deepseek-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@arikusi/deepseek-mcp-server` | npm | From 1.4.2 | 1.8.0 |
| `@arikusi/deepseek-mcp-server` | npm | From 1.4.2 | 1.8.0 |

## How do I fix CVE-2026-55605?

Upgrade @arikusi/deepseek-mcp-server to 1.8.0 or later.

## Is CVE-2026-55605 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55605 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55605 and fix it if it is affected.

What it is: CVE-2026-55605 is a medium-severity missing authorization vulnerability in arikusi deepseek-mcp-server, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55605 exists.

Affected packages and fixed versions:
- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.8.0
- @arikusi/deepseek-mcp-server (npm): affected from 1.4.2; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55605/ (Markdown: https://insights.sbomify.com/CVE-2026-55605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55605
- OSV: https://osv.dev/vulnerability/CVE-2026-55605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55605/
Summaries are generated and may contain mistakes; the official description above is the record.
