# CVE-2026-55607: Claude Code: Sandbox Escape via Git Worktree Path Confusion Allows Unsandboxed Code Execution

> Attackers can escape the sandbox and execute arbitrary code by exploiting git worktree path confusion and symlink manipulation in Claude Code.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** GHSA-7835-87q9-rgvv, MINI-67r7-78qr-hmcq, MINI-8cv7-4r7h-wrc4

## What is CVE-2026-55607?

CVE-2026-55607 is a high-severity path traversal vulnerability in anthropics claude-code, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool.  From 2.1.38 until 2.1.163, Claude Code's worktree handling allowed creation of worktrees named ".git" and navigation to worktrees outside the sandbox context, enabling git directory confusion attacks. By exploiting symlink manipulation and git fsmonitor execution during worktree operations, an attacker could overwrite files in the user's home directory (such as .zshenv), leading to code execution outside of seatbelt sandbox restrictions. Reliably exploiting this required the user to clone a malicious repository containing prompt injection content and run Claude Code against it. This vulnerability is fixed in 2.1.163.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55607?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | From 2.1.38 | 2.1.163 |
| `@anthropic-ai/claude-code` | npm | From 2.1.38 | 2.1.163 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-55607?

Upgrade @anthropic-ai/claude-code to 2.1.163 or later.

## Is CVE-2026-55607 being exploited?

There is no known exploitation of CVE-2026-55607 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55607 and fix it if it is affected.

What it is: CVE-2026-55607 is a high-severity path traversal vulnerability in anthropics claude-code, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55607 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected from 2.1.38; fixed in 2.1.163
- @anthropic-ai/claude-code (npm): affected from 2.1.38; fixed in 2.1.163

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55607/ (Markdown: https://insights.sbomify.com/CVE-2026-55607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55607
- OSV: https://osv.dev/vulnerability/CVE-2026-55607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55607/
Summaries are generated and may contain mistakes; the official description above is the record.
