CVE-2026-55615 Langroid: Neo4jChatAgent executes LLM-generated Cypher without validation (prompt-to-Cypher injection; config-conditional RCE), mirroring the SQLChatAgent bug fixed in CVE-2026-25879

Critical 9.2 Published Updated

Attackers can inject malicious Cypher queries via prompt injection to read/destroy graph data or execute OS commands if specific Neo4j procedures are enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55615?

CVE-2026-55615 is a critical code injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Langroid is a framework for building large-language-model-powered applications. Prior to version 0.65.5, Neo4jChatAgent passes LLM-generated Cypher queries straight to the Neo4j driver with no validation, no statement-type allowlist, and no opt-out gate. The query text is influenceable by prompt injection (direct user input or indirect content the agent reads back via RAG), so an attacker who can influence the prompt can read or destroy all graph data and, when APOC or dbms.security procedures are enabled on the server, achieve OS-command and filesystem access. This is the same defect class and threat model as the SQLChatAgent prompt-to-SQL-to-RCE issue fixed in version 0.63.0 (CVE-2026-25879); that fix did not extend to the neo4j module. Version 0.65.5 contains a fix for the neo4j module.

Weakness: CWE-74

Which versions are affected by CVE-2026-55615?

3 open source packages ship an affected version, including langroid.

PackageAffectedFixed in
langroid PyPIAll versions0.65.5
langroid PyPIAll versions0.65.5
langroid PyPIAll versions0.65.5

How do I fix CVE-2026-55615?

Upgrade langroid to 0.65.5 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-55615 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55615 exists.

Sources

Also known as GHSA-2pq5-3q89-j7cc, PYSEC-2026-2576.

Is CVE-2026-55615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free