# CVE-2026-55615: Langroid: Neo4jChatAgent executes LLM-generated Cypher without validation (prompt-to-Cypher injection; config-conditional RCE), mirroring the SQLChatAgent bug fixed in CVE-2026-25879

> Attackers can inject malicious Cypher queries via prompt injection to read/destroy graph data or execute OS commands if specific Neo4j procedures are enabled.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-2pq5-3q89-j7cc, PYSEC-2026-2576

## What is CVE-2026-55615?

CVE-2026-55615 is a critical code injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Langroid is a framework for building large-language-model-powered applications. Prior to version 0.65.5, Neo4jChatAgent passes LLM-generated Cypher queries straight to the Neo4j driver with no validation, no statement-type allowlist, and no opt-out gate. The query text is influenceable by prompt injection (direct user input or indirect content the agent reads back via RAG), so an attacker who can influence the prompt can read or destroy all graph data and, when APOC or dbms.security procedures are enabled on the server, achieve OS-command and filesystem access. This is the same defect class and threat model as the SQLChatAgent prompt-to-SQL-to-RCE issue fixed in version 0.63.0 (CVE-2026-25879); that fix did not extend to the neo4j module. Version 0.65.5 contains a fix for the neo4j module.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-55615?

3 open source packages ship an affected version, including langroid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langroid` | PyPI | All versions | 0.65.5 |
| `langroid` | PyPI | All versions | 0.65.5 |
| `langroid` | PyPI | All versions | 0.65.5 |

## How do I fix CVE-2026-55615?

Upgrade langroid to 0.65.5 or later.

## Is CVE-2026-55615 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55615 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55615 and fix it if it is affected.

What it is: CVE-2026-55615 is a critical code injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55615 exists.

Affected packages and fixed versions:
- langroid (PyPI): affected all versions; fixed in 0.65.5
- langroid (PyPI): affected all versions; fixed in 0.65.5
- langroid (PyPI): affected all versions; fixed in 0.65.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55615/ (Markdown: https://insights.sbomify.com/CVE-2026-55615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55615
- OSV: https://osv.dev/vulnerability/CVE-2026-55615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55615/
Summaries are generated and may contain mistakes; the official description above is the record.
