# CVE-2026-55617: Hydro: Insufficient session expiration when recreating sessions

> Attackers can replay stale session cookies to take over accounts and access or modify data due to insufficient session expiration in Hydro.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-94jp-7776-qj6q

## What is CVE-2026-55617?

CVE-2026-55617 is a medium-severity authentication bypass vulnerability in hydro-dev Hydro, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Hydro is a next-generation high-performance online judge platform. From 4.10.4 until 5.0.2, the session recreation logic in packages/hydrooj/src/service/layers/base.ts creates a replacement session token without deleting the previous token from the server-side session token store, so an old sid cookie can remain valid after logout or another renewal flow. An attacker who possesses a victim's previously valid stale cookie can replay it over HTTP or HTTPS without knowing the victim's username or password and without victim interaction at exploitation time. Successful replay can take over the victim's account, disclose private data, and permit unauthorized modification or deletion of data available to that account. This issue is fixed in version 5.0.2.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-55617?

2 open source packages ship an affected version, including hydrooj.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hydrooj` | npm | From 4.10.4 | 5.0.2 |
| `hydrooj` | npm | From 4.10.4 | 5.0.2 |

## How do I fix CVE-2026-55617?

Upgrade hydrooj to 5.0.2 or later.

## Is CVE-2026-55617 being exploited?

There is no known exploitation of CVE-2026-55617 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55617 and fix it if it is affected.

What it is: CVE-2026-55617 is a medium-severity authentication bypass vulnerability in hydro-dev Hydro, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55617 in the wild and no public exploit code.

Affected packages and fixed versions:
- hydrooj (npm): affected from 4.10.4; fixed in 5.0.2
- hydrooj (npm): affected from 4.10.4; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55617/ (Markdown: https://insights.sbomify.com/CVE-2026-55617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55617
- OSV: https://osv.dev/vulnerability/CVE-2026-55617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55617/
Summaries are generated and may contain mistakes; the official description above is the record.
