# CVE-2026-55618: eml_parser: URL extraction bypass via HTML entities in URLs

> Attackers can hide malicious URLs in emails using HTML entities, bypassing security gateways that rely on eml_parser for threat detection.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-fxgq-9m89-cxj9, PYSEC-2026-3831

## What is CVE-2026-55618?

CVE-2026-55618 is a medium-severity vulnerability in GOVCERT-LU eml_parser, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

eml_parser serves as a python module for parsing eml files and returning various information found in the e-mail as well as computed information. Prior to 3.0.2, the clean_found_uri function in eml_parser/parser.py validates potential URL strings before unescaping HTML entities used for colon, slash, or period characters. Valid encoded URLs and their host names are therefore rejected and omitted from the extracted URL and domain lists. Email security gateways and SOC pipelines that use those lists as indicators of compromise may fail to submit the hidden URLs to threat intelligence feeds, reputation services, or sandboxes, allowing malicious links to bypass inspection. This issue is fixed in version 3.0.2.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-55618?

3 open source packages ship an affected version, including eml_parser and eml-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eml_parser` | PyPI | All versions | 3.0.2 |
| `eml-parser` | PyPI | All versions | 3.0.2 |
| `eml-parser` | PyPI | All versions | 3.0.2 |

## How do I fix CVE-2026-55618?

Upgrade eml_parser to 3.0.2 or later.

## Is CVE-2026-55618 being exploited?

There is no known exploitation of CVE-2026-55618 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55618 and fix it if it is affected.

What it is: CVE-2026-55618 is a medium-severity vulnerability in GOVCERT-LU eml_parser, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55618 in the wild and no public exploit code.

Affected packages and fixed versions:
- eml_parser (PyPI): affected all versions; fixed in 3.0.2
- eml-parser (PyPI): affected all versions; fixed in 3.0.2
- eml-parser (PyPI): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55618/ (Markdown: https://insights.sbomify.com/CVE-2026-55618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55618
- OSV: https://osv.dev/vulnerability/CVE-2026-55618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55618/
Summaries are generated and may contain mistakes; the official description above is the record.
