{"answers":{"affected":"3 open source packages ship an affected version, including eml_parser and eml-parser.","exploited":"There is no known exploitation of CVE-2026-55619 in the wild and no public exploit code.","fix":"Upgrade eml_parser to 3.0.2 or later.","what":"CVE-2026-55619 is a medium-severity denial of service vulnerability in GOVCERT-LU eml_parser, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55619 and fix it if it is affected.\n\nWhat it is: CVE-2026-55619 is a medium-severity denial of service vulnerability in GOVCERT-LU eml_parser, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55619 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eml_parser (PyPI): affected all versions; fixed in 3.0.2\n- eml-parser (PyPI): affected all versions; fixed in 3.0.2\n- eml-parser (PyPI): affected all versions; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55619/ (Markdown: https://insights.sbomify.com/CVE-2026-55619/index.md)","id":"CVE-2026-55619","markdown":"https://insights.sbomify.com/CVE-2026-55619/index.md","name":"CVE-2026-55619","record":{"aliases":["GHSA-m66c-fw79-6359","PYSEC-2026-3833"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python email parser","requires_auth":"none","summary":"Attackers can cause denial of service in applications using eml_parser by submitting emails with deeply nested parentheses, crashing the parser.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-1124","name":"Excessively Deep Nesting"}],"description":"eml_parser serves as a python module for parsing eml files and returning various information found in the e-mail as well as computed information. Prior to 3.0.2, eml_parser.parser.HeaderParser.header_fetch_parse in eml_parser/parser.py uses email.utils.getaddresses() to parse address-bearing e-mail headers. A deeply nested CFWS comment construct exhausts the standard-library recursive descent parser's call stack and raises RecursionError, which is not caught and therefore aborts parsing of the entire message. An attacker can disrupt SOC pipelines that process untrusted EML files, although callers already need to handle exceptions from malformed or pathological messages. This issue is fixed in version 3.0.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"eml_parser: Parser DoS via deeply nested parentheses in e-mail headers","id":"CVE-2026-55619","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"eml_parser: DoS via deeply nested parens in Received headers","id":"CVE-2026-55620"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"eml-parser","purl":"pkg:pypi/eml-parser","source":"GHSA-m66c-fw79-6359"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"eml-parser","purl":"pkg:pypi/eml-parser","source":"PYSEC-2026-3833"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"eml_parser","purl":null,"source":"GHSA-m66c-fw79-6359"}],"prev":{"headline":"eml_parser: URL extraction bypass via HTML entities in URLs","id":"CVE-2026-55618"},"products":["eml_parser"],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["GOVCERT-LU"]},"summary":"Attackers can cause denial of service in applications using eml_parser by submitting emails with deeply nested parentheses, crashing the parser.","url":"https://insights.sbomify.com/CVE-2026-55619/"}