# CVE-2026-55631: DataEase: Path Traversal Leading to Arbitrary File Deletion via Font Management

> Authenticated attackers can delete arbitrary files in the application container via path traversal in the font management module.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-r99p-w8fc-93g6

## What is CVE-2026-55631?

CVE-2026-55631 is a high-severity path traversal vulnerability in dataease, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the font management module allows authenticated users to submit an arbitrary fileTransName when creating a font record; when the record is later deleted, the backend concatenates that stored value with the font storage directory and passes it to FileUtils.deleteFile() without path traversal sanitization, allowing deletion of arbitrary writable files in the application container. This issue is fixed in version 2.10.24.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55631?


## How do I fix CVE-2026-55631?

No fix has been published for CVE-2026-55631 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55631 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55631 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55631 and fix it if it is affected.

What it is: CVE-2026-55631 is a high-severity path traversal vulnerability in dataease, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55631 exists.

Affected product: dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55631/ (Markdown: https://insights.sbomify.com/CVE-2026-55631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55631
- OSV: https://osv.dev/vulnerability/CVE-2026-55631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55631/
Summaries are generated and may contain mistakes; the official description above is the record.
