# CVE-2026-55633: DataEase H2 RCE via Zip Protocol & File Dropper Fix bypass

> Authenticated attackers can upload malicious zip archives disguised as fonts to achieve remote code execution in DataEase.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-8x36-774q-pwqg

## What is CVE-2026-55633?

CVE-2026-55633 is a high-severity vulnerability in dataease, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, a bypass of the H2 zip protocol and file dropper fix allows an authenticated attacker to upload a zip archive disguised with a .ttf extension through FontManage.saveFile and then exploit it through the zip protocol to achieve remote code execution. This issue is fixed in version 2.10.24.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-55633?


## How do I fix CVE-2026-55633?

No fix has been published for CVE-2026-55633 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55633 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55633 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55633 and fix it if it is affected.

What it is: CVE-2026-55633 is a high-severity vulnerability in dataease, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55633 exists.

Affected product: dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55633/ (Markdown: https://insights.sbomify.com/CVE-2026-55633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55633
- OSV: https://osv.dev/vulnerability/CVE-2026-55633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55633/
Summaries are generated and may contain mistakes; the official description above is the record.
