CVE-2026-55634 Pimcore: Remote Code Execution via DataObject Class-Definition Field Name
Authenticated users can inject PHP code and SQL identifiers via DataObject field names, leading to remote code execution and schema modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55634?
CVE-2026-55634 is a critical code injection vulnerability in pimcore, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.19, 12.3.10, and 2026.1.6, the class-definition import endpoint /pimcore-studio/api/class/definition/configuration-view/detail/{id}/import accepts a DataObject field name that is emitted without an identifier allowlist by lib/DataObject/ClassBuilder/FieldDefinitionPropertiesBuilder.php into generated PHP properties and by models/DataObject/ClassDefinition/Helper/Dao.php into ALTER TABLE identifiers. An authenticated user with the objects permission can inject PHP syntax into the generated DataObject class, causing attacker-controlled code in generated var/classes/DataObject/.php files to run when an object of that class is instantiated, and can also inject SQL identifier content into schema-changing statements. The central models/DataObject/ClassDefinition/Data.php::setName() validation did not reject semicolons, braces, backticks, spaces, or other non-identifier characters. This issue is fixed in versions 11.5.19, 12.3.10, and 2026.1.6.
Which versions are affected by CVE-2026-55634?
4 open source packages ship an affected version, including pimcore/pimcore.
| Package | Affected | Fixed in |
|---|---|---|
pimcore/pimcore Packagist | All versions | 12.3.10 |
pimcore/pimcore Packagist | All versions | 12.3.10 |
pimcore/pimcore Packagist | From 2026.1.0 | 2026.1.6 |
pimcore/pimcore Packagist | From 2026.1.0 | 2026.1.6 |
How do I fix CVE-2026-55634?
Upgrade pimcore/pimcore to a fixed version for your release line: 12.3.10 or 2026.1.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55634 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55634 exists.
Sources
Also known as GHSA-9x44-4gxf-8c25.