# CVE-2026-55638: 9router: Unauthenticated LLM proxy access via /codex rewrite authorization bypass

> Unauthenticated attackers can bypass API key checks on the /codex endpoint to use stored LLM provider credentials for unauthorized upstream calls.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-8gmq-j984-vp4r

## What is CVE-2026-55638?

CVE-2026-55638 is a high-severity authentication bypass vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.2, 9router protects /v1, /v1beta, /api/v1, and /api/v1beta in src/dashboardGuard.js but omits /codex before next.config.mjs rewrites /codex/* to /api/v1/responses. A remote unauthenticated attacker can send requests to /codex/* to bypass the API-key gate and cause the server to make upstream provider calls using operator-stored LLM provider credentials. This issue is fixed in version 0.5.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-55638?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.5.2 |
| `9router` | npm | All versions | 0.5.2 |

## How do I fix CVE-2026-55638?

Upgrade 9router to 0.5.2 or later.

## Is CVE-2026-55638 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55638 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55638 and fix it if it is affected.

What it is: CVE-2026-55638 is a high-severity authentication bypass vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55638 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.5.2
- 9router (npm): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55638/ (Markdown: https://insights.sbomify.com/CVE-2026-55638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55638
- OSV: https://osv.dev/vulnerability/CVE-2026-55638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55638/
Summaries are generated and may contain mistakes; the official description above is the record.
