# CVE-2026-55640: nextcloud-mcp-server: Unauthenticated `POST /webhooks/nextcloud` allows arbitrary vector data deletion when `WEBHOOK_SECRET` is unset ( default )

> Unauthenticated attackers can delete vector data or destroy semantic search indexes in Nextcloud MCP Server due to missing webhook authentication.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-8vh3-g2qg-2h2c, PYSEC-2026-3866

## What is CVE-2026-55640?

CVE-2026-55640 is a critical missing authorization vulnerability in cbcoutinho nextcloud-mcp-server, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nextcloud MCP Server is a production-ready MCP server that connects AI assistants to a Nextcloud instance. Prior to 0.117.2, the POST /webhooks/nextcloud endpoint in nextcloud_mcp_server/vector/webhook_receiver.py has no authentication by default because WEBHOOK_SECRET defaults to None and startup validation does not require it. When WEBHOOK_SECRET is unset, handle_nextcloud_webhook() accepts unauthenticated requests. The payload["user"]["uid"] field parsed in nextcloud_mcp_server/vector/webhook_parser.py is attacker-controlled and is used without an authenticated-session cross-check for Qdrant operations, allowing a network attacker to delete or trigger re-indexing of vector embeddings for any user and to destroy the semantic search index by sending forged deletion events. This issue is fixed in version 0.117.2.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-55640?

3 open source packages ship an affected version, including nextcloud-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud-mcp-server` | PyPI | All versions | 0.117.2 |
| `nextcloud-mcp-server` | PyPI | All versions | 0.117.2 |
| `nextcloud-mcp-server` | PyPI | All versions | 0.117.2 |

## How do I fix CVE-2026-55640?

Upgrade nextcloud-mcp-server to 0.117.2 or later.

## Is CVE-2026-55640 being exploited?

There is no known exploitation of CVE-2026-55640 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55640 and fix it if it is affected.

What it is: CVE-2026-55640 is a critical missing authorization vulnerability in cbcoutinho nextcloud-mcp-server, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55640 in the wild and no public exploit code.

Affected packages and fixed versions:
- nextcloud-mcp-server (PyPI): affected all versions; fixed in 0.117.2
- nextcloud-mcp-server (PyPI): affected all versions; fixed in 0.117.2
- nextcloud-mcp-server (PyPI): affected all versions; fixed in 0.117.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55640/ (Markdown: https://insights.sbomify.com/CVE-2026-55640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55640
- OSV: https://osv.dev/vulnerability/CVE-2026-55640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55640/
Summaries are generated and may contain mistakes; the official description above is the record.
