# CVE-2026-55641: 9router: Unauthenticated `/v1` proxy access via `Host`-header spoofing → open AI relay + SSRF

> Remote attackers can bypass authentication and trigger server-side requests to internal hosts by spoofing the Host header in 9router.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-86m2-fcxq-5q7c

## What is CVE-2026-55641?

CVE-2026-55641 is a high-severity server-side request forgery vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.2, 9router determines whether a /v1 LLM proxy request is local by reading the client-controlled Host header, allowing a remote unauthenticated attacker to send Host: localhost and bypass API-key authentication. In the default configuration, this exposes the /v1 proxy to upstream provider calls using stored provider credentials and allows /v1/search with the searxng provider_options.baseUrl parameter to drive server-side requests to internal or cloud-metadata hosts. This issue is fixed in version 0.5.2.

Weakness: CWE-348 (Use of Less Trusted Source), CWE-918 (Server-Side Request Forgery), CWE-290 (Authentication Bypass by Spoofing), CWE-1327 (Binding to an Unrestricted IP Address)

## Which versions are affected by CVE-2026-55641?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.5.2 |
| `9router` | npm | All versions | 0.5.2 |

## How do I fix CVE-2026-55641?

Upgrade 9router to 0.5.2 or later.

## Is CVE-2026-55641 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55641 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55641 and fix it if it is affected.

What it is: CVE-2026-55641 is a high-severity server-side request forgery vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55641 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.5.2
- 9router (npm): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55641/ (Markdown: https://insights.sbomify.com/CVE-2026-55641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55641
- OSV: https://osv.dev/vulnerability/CVE-2026-55641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55641/
Summaries are generated and may contain mistakes; the official description above is the record.
