CVE-2026-55646 vLLM speech-to-text endpoints allocate full upload before enforcing the audio file-size limit
Attackers can cause denial of service by uploading oversized audio files, forcing vLLM to exhaust memory before enforcing size limits.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55646?
CVE-2026-55646 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
vLLM is an inference and serving engine for large language models. From 0.22.0 to 0.23.0, the /v1/audio/transcriptions and /v1/audio/translations routes call request.file.read() to fully materialize an uploaded audio file into memory before vLLM checks the documented VLLM_MAX_AUDIO_CLIP_FILESIZE_MB compressed upload size limit (default 25 MB) later in the speech-to-text preprocessing step, so an API caller who can reach those routes can submit an oversized multipart upload and cause vLLM to allocate memory proportional to the uploaded file size before the request is rejected as too large, creating memory pressure or terminating the process depending on deployment resource limits. This issue is fixed in version 0.24.0.
Which versions are affected by CVE-2026-55646?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | From 0.22.0 | 0.24.0 |
vllm PyPI | From 0.22.0 | 0.24.0 |
vllm PyPI | From 0.22.0 | 0.24.0 |
Products include Vllm Vllm.
How do I fix CVE-2026-55646?
Upgrade vllm to 0.24.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-55646 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55646 exists.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-v82g-2437-67m2, MINI-r39v-r69q-6cwv, MINI-r856-96jf-9rxq, PYSEC-2026-2305.