# CVE-2026-55646: vLLM speech-to-text endpoints allocate full upload before enforcing the audio file-size limit

> Attackers can cause denial of service by uploading oversized audio files, forcing vLLM to exhaust memory before enforcing size limits.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-v82g-2437-67m2, MINI-r39v-r69q-6cwv, MINI-r856-96jf-9rxq, PYSEC-2026-2305

## What is CVE-2026-55646?

CVE-2026-55646 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. From 0.22.0 to 0.23.0, the /v1/audio/transcriptions and /v1/audio/translations routes call request.file.read() to fully materialize an uploaded audio file into memory before vLLM checks the documented VLLM_MAX_AUDIO_CLIP_FILESIZE_MB compressed upload size limit (default 25 MB) later in the speech-to-text preprocessing step, so an API caller who can reach those routes can submit an oversized multipart upload and cause vLLM to allocate memory proportional to the uploaded file size before the request is rejected as too large, creating memory pressure or terminating the process depending on deployment resource limits. This issue is fixed in version 0.24.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55646?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.22.0 | 0.24.0 |
| `vllm` | PyPI | From 0.22.0 | 0.24.0 |
| `vllm` | PyPI | From 0.22.0 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-55646?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-55646 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55646 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55646 and fix it if it is affected.

What it is: CVE-2026-55646 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55646 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.22.0; fixed in 0.24.0
- vllm (PyPI): affected from 0.22.0; fixed in 0.24.0
- vllm (PyPI): affected from 0.22.0; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55646/ (Markdown: https://insights.sbomify.com/CVE-2026-55646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55646
- OSV: https://osv.dev/vulnerability/CVE-2026-55646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55646/
Summaries are generated and may contain mistakes; the official description above is the record.
