CVE-2026-55663 mediasoup: SCTP state cookie lacks cryptographic authentication, enabling unauthorized association establishment (RFC 9260 violation)
An on-path attacker can forge SCTP state cookies to establish unauthorized associations and inject DataChannel messages in mediasoup when DTLS is disabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55663?
CVE-2026-55663 is a medium-severity vulnerability in versatica mediasoup, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
mediasoup is a WebRTC video conferencing system. From version 3.20.0 until 3.20.6 for the npm package and from 0.22.0 until 0.22.5 for the Rust crate, mediasoup's built-in SCTP stack authenticates state cookies using only the hardcoded msworker and 0xAD81 magic values instead of a per-instance secret and HMAC, contrary to RFC 9260 Section 5.1.3. The cookie structure and validation in worker/include/RTC/SCTP/association/StateCookie.hpp and worker/src/RTC/SCTP/association/StateCookie.cpp allow an on-path attacker targeting PlainTransport or PipeTransport with SCTP enabled and without DTLS protection to forge a COOKIE-ECHO whose packet verification tag matches the attacker-controlled localVerificationTag. The forged cookie passes StateCookie::IsMediasoupStateCookie() and Association::HandleReceivedCookieEchoChunk(), establishes an unauthorized SCTP association, and permits DataChannel message injection as a trusted peer. WebRtcTransport is not affected because its SCTP runs inside DTLS. This issue is fixed in npm version 3.20.6 and Rust crate version 0.22.5.
Weakness: CWE-345
Which versions are affected by CVE-2026-55663?
4 open source packages ship an affected version, including mediasoup.
| Package | Affected | Fixed in |
|---|---|---|
mediasoup crates.io | From 0.22.0 | 0.22.5 |
mediasoup crates.io | From 0.22.0 | 0.22.5 |
mediasoup npm | From 3.20.0 | 3.20.6 |
mediasoup npm | From 3.20.0 | 3.20.6 |
How do I fix CVE-2026-55663?
Upgrade mediasoup to a fixed version for your release line: 0.22.5 or 3.20.6.
Is CVE-2026-55663 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55663 exists.
Sources
Also known as GHSA-p7x2-g5cq-fhmq.