{"answers":{"affected":"2 open source packages ship an affected version, including com.powsybl:powsybl-computation-local.","exploited":"There is no known exploitation of CVE-2026-55673 in the wild and no public exploit code.","fix":"Upgrade com.powsybl:powsybl-computation-local to 7.2.2 or later.","what":"CVE-2026-55673 is a high-severity command injection vulnerability in powsybl-core, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55673 and fix it if it is affected.\n\nWhat it is: CVE-2026-55673 is a high-severity command injection vulnerability in powsybl-core, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55673 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.powsybl:powsybl-computation-local (Maven): affected all versions; fixed in 7.2.2\n- com.powsybl:powsybl-computation-local (Maven): affected all versions; fixed in 7.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55673/ (Markdown: https://insights.sbomify.com/CVE-2026-55673/index.md)","id":"CVE-2026-55673","markdown":"https://insights.sbomify.com/CVE-2026-55673/index.md","name":"CVE-2026-55673","record":{"aliases":["GHSA-jqvf-j3ww-r8c7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Power system framework","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary shell commands via unsanitized inputs in PowSyBl's local command executors, affecting power system analysis tools.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to 7.2.2, UnixLocalCommandExecutor and WindowsLocalCommandExecutor concatenate command arguments and environment variables into strings interpreted through bash -c or cmd /c without sufficient escaping. Attacker-controlled values reaching UnixLocalCommandExecutor.execute, WindowsLocalCommandExecutor.execute, LocalComputationManager.execute, ParallelLoadFlowActionSimulator.run, ActionSimulatorTool.run, AmplModelRunner.run, or AmplModelRunner.runAsync can break out of the intended command and execute arbitrary shell commands as the JVM user. The affected itools paths include action-simulator with task-count, security-analysis with external, and dynamic-security-analysis. Downstream CLI tools, libraries, REST front ends, and multi-tenant grid-analysis services that forward less-trusted contingency identifiers or computation parameters into these APIs can expose the injection remotely. This issue is fixed in version 7.2.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PowSyBl: Command Injection in LocalCommandExecutor-s","id":"CVE-2026-55673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Discourse: Cache poisoning/XSS via color scheme cookies","id":"CVE-2026-55674"},"packages":[{"ecosystem":"Maven","fixed":["7.2.2"],"introduced":["0"],"last_affected":[],"package":"com.powsybl:powsybl-computation-local","purl":null,"source":"GHSA-jqvf-j3ww-r8c7"},{"ecosystem":"Maven","fixed":["7.2.2"],"introduced":["0"],"last_affected":[],"package":"com.powsybl:powsybl-computation-local","purl":"pkg:maven/com.powsybl/powsybl-computation-local","source":"GHSA-jqvf-j3ww-r8c7"}],"prev":{"headline":"ZITADEL: Missing client_id binding in OIDC authorization code exchange and refresh token flows (RFC 6749 Section 4.1.3 violation)","id":"CVE-2026-55672"},"products":["powsybl-core"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["powsybl"]},"summary":"Attackers can execute arbitrary shell commands via unsanitized inputs in PowSyBl's local command executors, affecting power system analysis tools.","url":"https://insights.sbomify.com/CVE-2026-55673/"}