# CVE-2026-55673: PowSyBl: Command Injection in LocalCommandExecutor-s

> Attackers can execute arbitrary shell commands via unsanitized inputs in PowSyBl's local command executors, affecting power system analysis tools.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-jqvf-j3ww-r8c7

## What is CVE-2026-55673?

CVE-2026-55673 is a high-severity command injection vulnerability in powsybl-core, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to 7.2.2, UnixLocalCommandExecutor and WindowsLocalCommandExecutor concatenate command arguments and environment variables into strings interpreted through bash -c or cmd /c without sufficient escaping. Attacker-controlled values reaching UnixLocalCommandExecutor.execute, WindowsLocalCommandExecutor.execute, LocalComputationManager.execute, ParallelLoadFlowActionSimulator.run, ActionSimulatorTool.run, AmplModelRunner.run, or AmplModelRunner.runAsync can break out of the intended command and execute arbitrary shell commands as the JVM user. The affected itools paths include action-simulator with task-count, security-analysis with external, and dynamic-security-analysis. Downstream CLI tools, libraries, REST front ends, and multi-tenant grid-analysis services that forward less-trusted contingency identifiers or computation parameters into these APIs can expose the injection remotely. This issue is fixed in version 7.2.2.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55673?

2 open source packages ship an affected version, including com.powsybl:powsybl-computation-local.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.powsybl:powsybl-computation-local` | Maven | All versions | 7.2.2 |
| `com.powsybl:powsybl-computation-local` | Maven | All versions | 7.2.2 |

## How do I fix CVE-2026-55673?

Upgrade com.powsybl:powsybl-computation-local to 7.2.2 or later.

## Is CVE-2026-55673 being exploited?

There is no known exploitation of CVE-2026-55673 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55673 and fix it if it is affected.

What it is: CVE-2026-55673 is a high-severity command injection vulnerability in powsybl-core, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55673 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.powsybl:powsybl-computation-local (Maven): affected all versions; fixed in 7.2.2
- com.powsybl:powsybl-computation-local (Maven): affected all versions; fixed in 7.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55673/ (Markdown: https://insights.sbomify.com/CVE-2026-55673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55673
- OSV: https://osv.dev/vulnerability/CVE-2026-55673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55673/
Summaries are generated and may contain mistakes; the official description above is the record.
