CVE-2026-55674 Discourse: Cache poisoning/XSS via color scheme cookies
Unauthenticated attackers can inject arbitrary JavaScript via crafted cookies, bypassing CSP to execute code in visitors' browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55674?
CVE-2026-55674 is a critical cross-site scripting vulnerability in discourse, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, an unauthenticated attacker could send a single request with a crafted color_scheme_id (or dark_scheme_id) cookie to inject arbitrary HTML into a Discourse page. Because the cookie value was rendered into a color scheme tag without escaping, the attacker could break out of the attribute and inject a tag that bypassed Discourse's nonce-based Content Security Policy, resulting in arbitrary JavaScript execution in visitors' browsers. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-55674?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |
How do I fix CVE-2026-55674?
Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-55674 being exploited?
There is no known exploitation of CVE-2026-55674 in the wild and no public exploit code.
Sources
Also known as BIT-discourse-2026-55674, GHSA-qx4v-rg4v-pm2g.