# CVE-2026-55677: Echo: Encoded slash (%2F) bypasses route-level protection and exposes static files

> Attackers can bypass route protections and read unauthorized static files by exploiting inconsistent URL decoding in the Echo Go web framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** CLEANSTART-2026-JO59032, CLEANSTART-2026-ON16702, CLEANSTART-2026-SS30538, CLSA-2026-1790266264, CLSA-2026-1790972556, DEBIAN-CVE-2026-55677, GHSA-vfp3-v2gw-7wfq, GO-2026-6293, MINI-4r99-gjw3-c4h3, MINI-8x8w-92x7-957f, MINI-c5cj-r3mr-xhp4, MINI-h269-23wr-v2hf, MINI-hcpr-6rhj-7mmh, MINI-m24c-446p-84f8, MINI-qpr2-3gm3-xjrx, MINI-r2qw-xfr6-xwrc, MINI-rw2j-hpp8-8fx6, MINI-vqgp-3x75-57ww, ROOT-APP-GOBINARY-CVE-2026-55677, UBUNTU-CVE-2026-55677

## What is CVE-2026-55677?

CVE-2026-55677 is a high-severity path traversal vulnerability in labstack echo, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Echo is a Go web framework. Prior to 4.15.3 and 5.2.0, Echo's router and static file handler disagree on URL path decoding. The router matches routes using the raw encoded path (preserving %2F as-is), while StaticDirectoryHandler unescapes %2F to / before resolving filesystem paths. This allows an attacker to bypass route-level access controls and read static files without authorization. This vulnerability is fixed in 4.15.3 and 5.2.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55677?

8 open source packages ship an affected version, including github.com/labstack/echo/v4, github.com/labstack/echo and github.com/labstack/echo/v5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v4` | Go | All versions | 4.15.3 |
| `github.com/labstack/echo/v4` | Go | All versions | 4.15.3 |
| `github.com/labstack/echo/v4` | Go | All versions | 4.15.3 |
| `github.com/labstack/echo` | Go | All versions to 3.3.10 | None |
| `github.com/labstack/echo` | Go | All versions to 3.3.10 | None |
| `github.com/labstack/echo/v5` | Go | All versions | 5.2.0 |
| `github.com/labstack/echo/v5` | Go | All versions | 5.2.0 |
| `github.com/labstack/echo/v5` | Go | All versions | 5.2.0 |

## How do I fix CVE-2026-55677?

Upgrade github.com/labstack/echo/v4 to 4.15.3 or later.

## Is CVE-2026-55677 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55677 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55677 and fix it if it is affected.

What it is: CVE-2026-55677 is a high-severity path traversal vulnerability in labstack echo, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55677 exists.

Affected packages and fixed versions:
- github.com/labstack/echo/v4 (Go): affected all versions; fixed in 4.15.3
- github.com/labstack/echo/v4 (Go): affected all versions; fixed in 4.15.3
- github.com/labstack/echo/v4 (Go): affected all versions; fixed in 4.15.3
- github.com/labstack/echo (Go): affected all versions up to 3.3.10; no fix listed
- github.com/labstack/echo (Go): affected all versions up to 3.3.10; no fix listed
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.2.0
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.2.0
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55677/ (Markdown: https://insights.sbomify.com/CVE-2026-55677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55677
- OSV: https://osv.dev/vulnerability/CVE-2026-55677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55677/
Summaries are generated and may contain mistakes; the official description above is the record.
