# CVE-2026-55685: React Router: Unauthenticated Denial of Service via Inefficient Route Matching

> Unauthenticated attackers can cause denial of service via inefficient route matching in the manifest endpoint, affecting server-side rendering applications.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** CLSA-2026-1784856417, CLSA-2026-1792139276, CLSA-2026-1792253398, CLSA-2026-1792253415, CLSA-2026-1792419113, CLSA-2026-1792419191, CLSA-2026-1792419269, CLSA-2026-1792419625, CLSA-2026-1792421943, CLSA-2026-1792424732, CLSA-2026-1792425407, CLSA-2026-1792428108, CLSA-2026-1792430032, CLSA-2026-1793110184, GHSA-chx6-hx7r-mcp5, ROOT-APP-NPM-CVE-2026-55685

## What is CVE-2026-55685?

CVE-2026-55685 is a high-severity denial of service vulnerability in remix-run react-router, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. In versions 7.0.0 through 7.17.0, the manifest endpoint could be accessed via unauthenticated targeted requests that would put heavy load on the server and slow down response times. This issue is a follow up to CVE-2026-42342, and does not does not impact React Router applications using Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been fixed in version 7.18.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55685?

2 open source packages ship an affected version, including react-router. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 7.0.0 | 7.18.0 |
| `react-router` | npm | From 7.0.0 | 7.18.0 |

Products: Shopify React-Router.

## How do I fix CVE-2026-55685?

Upgrade react-router to 7.18.0 or later.

## Is CVE-2026-55685 being exploited?

There is no known exploitation of CVE-2026-55685 in the wild and no public exploit code.

## Other vulnerabilities in remix-run react-router

- [CVE-2026-21884](https://insights.sbomify.com/CVE-2026-21884/): React Router SSR XSS in ScrollRestoration (high 8.2)
- [CVE-2026-42211](https://insights.sbomify.com/CVE-2026-42211/): React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE (high 8.1)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)
- [CVE-2025-59057](https://insights.sbomify.com/CVE-2025-59057/): React Router has XSS Vulnerability (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55685 and fix it if it is affected.

What it is: CVE-2026-55685 is a high-severity denial of service vulnerability in remix-run react-router, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55685 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-router (npm): affected from 7.0.0; fixed in 7.18.0
- react-router (npm): affected from 7.0.0; fixed in 7.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55685/ (Markdown: https://insights.sbomify.com/CVE-2026-55685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55685
- OSV: https://osv.dev/vulnerability/CVE-2026-55685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55685/
Summaries are generated and may contain mistakes; the official description above is the record.
