# CVE-2026-55686: Podman: WORKDIR symlink traversal vulnerability

> A malicious container image with a symlinked WORKDIR can create directories or modify ownership on the host filesystem, potentially leading to privilege escalation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** AZL-91299, BELL-CVE-2026-55686, CLSA-2026-1782985538, CLSA-2026-1782987821, DEBIAN-CVE-2026-55686, GHSA-q6r4-3wmg-fwcq, GO-2026-5568, MINI-mrcr-43m6-m728, UBUNTU-CVE-2026-55686

## What is CVE-2026-55686?

CVE-2026-55686 is a medium-severity path traversal vulnerability in podman-container-tools podman, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Podman is a tool for managing OCI containers and pods. From 3.0.0 until 5.7.1, running a malicious container image where the WORKDIR path contains a symlink can create a directory or modify ownership on the host filesystem. Modified ownership is less likely to happen as that requires help from an untrusted/malicious process that mutates the host filesystem tree during dereferencing of the WORKDIR path, to trigger a race condition. This vulnerability is fixed in 5.7.1.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2026-55686?

11 open source packages ship an affected version, including github.com/containers/podman/v3, github.com/containers/podman and github.com/containers/podman/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions to 3.4.7 | None |
| `github.com/containers/podman/v3` | Go | All versions to 3.4.7 | None |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | All versions to 4.9.5 | None |
| `github.com/containers/podman/v4` | Go | All versions to 4.9.5 | None |
| `github.com/containers/podman/v5` | Go | All versions | 5.7.1 |
| `github.com/containers/podman/v5` | Go | All versions | 5.7.1 |
| `github.com/containers/podman/v5` | Go | All versions | 5.7.1 |

Products: Podman Project Podman.

## How do I fix CVE-2026-55686?

Upgrade to a fixed version.

## Is CVE-2026-55686 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55686 exists.

## Other vulnerabilities in podman-container-tools podman

- [CVE-2026-57231](https://insights.sbomify.com/CVE-2026-57231/): Podman: Malformed Image can trick podman run into leaking host environment variables into the container (high 7.5)
- [CVE-2022-2738](https://insights.sbomify.com/CVE-2022-2738/): Use after free in podman (high 7.5)
- [CVE-2022-2989](https://insights.sbomify.com/CVE-2022-2989/): Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification (high 7.1)
- [CVE-2021-20188](https://insights.sbomify.com/CVE-2021-20188/): Improper Authorization in github.com/containers/libpod (high 7.0)
- [CVE-2023-0778](https://insights.sbomify.com/CVE-2023-0778/): Podman Time-of-check Time-of-use (TOCTOU) Race Condition (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55686 and fix it if it is affected.

What it is: CVE-2026-55686 is a medium-severity path traversal vulnerability in podman-container-tools podman, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55686 exists.

Affected packages and fixed versions:
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions up to 3.4.7; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions up to 3.4.7; no fix listed
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions up to 4.9.5; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions up to 4.9.5; no fix listed
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.7.1
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.7.1
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55686/ (Markdown: https://insights.sbomify.com/CVE-2026-55686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55686
- OSV: https://osv.dev/vulnerability/CVE-2026-55686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55686/
Summaries are generated and may contain mistakes; the official description above is the record.
