# CVE-2026-55689: OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset

> Attackers can authenticate to OpenFGA using tokens from unrelated services if OIDC audience validation is not explicitly configured.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** CLEANSTART-2026-GI00797, CLEANSTART-2026-RC76229, CLEANSTART-2026-RF10343, CLEANSTART-2026-SL02652, ECHO-6ebd-1b12-c874, GHSA-hcxc-wf8j-23hv, GO-2026-5423, MINI-2569-x57v-fr6m, MINI-2qvc-mvhw-ffrq, MINI-38jm-2xf3-8w7w, MINI-663j-75fw-hcjj, MINI-6f2x-6x3f-jh2w, MINI-87m3-fvcp-v393, MINI-94wp-mvjm-px2r, MINI-f8c2-874f-hrpm, MINI-f9mr-6vxp-qg6f, MINI-m5ww-2vx7-6rph, MINI-p64h-m4j5-8whx, MINI-pmgr-6x72-9wj7, MINI-r5g8-cg4h-46qg, MINI-r9pv-p39r-fc69, MINI-wq8f-pxjx-wrqm, MINI-ww2c-qvvx-cr8f, MINI-x5xx-6343-rm2r, MINI-xgm6-hvh4-j53h

## What is CVE-2026-55689?

CVE-2026-55689 is a medium-severity authentication bypass vulnerability in openfga, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, OpenFGA's OIDC authenticator skipped JWT audience validation when authn.method was set to oidc, authn.oidc.issuer was configured, and authn.oidc.audience was not set, allowing a token minted for an unrelated service by the same identity provider to authenticate to OpenFGA. This issue is fixed in 1.18.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-55689?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-55689?

Upgrade github.com/openfga/openfga to 1.18.0 or later.

## Is CVE-2026-55689 being exploited?

There is no known exploitation of CVE-2026-55689 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)
- [CVE-2025-46331](https://insights.sbomify.com/CVE-2025-46331/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55689 and fix it if it is affected.

What it is: CVE-2026-55689 is a medium-severity authentication bypass vulnerability in openfga, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55689 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55689/ (Markdown: https://insights.sbomify.com/CVE-2026-55689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55689
- OSV: https://osv.dev/vulnerability/CVE-2026-55689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55689/
Summaries are generated and may contain mistakes; the official description above is the record.
