# CVE-2026-55691: EmbedVideo Extension : Stored XSS via unsanitized class passed to template

> A stored XSS vulnerability in the EmbedVideo MediaWiki extension allows attackers to inject malicious scripts via unsanitized class attributes, affecting wiki visitors.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-7h5p-637f-jfr7

## What is CVE-2026-55691?

CVE-2026-55691 is a high-severity cross-site scripting vulnerability in StarCitizenWiki mediawiki-extensions-EmbedVideo, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The EmbedVideo Extension is a MediaWiki extension which adds a parser function called #ev and various parser tags for embedding video clips from various video sharing services. Prior to 4.1.0, EmbedHtmlFormatter::toHtml in includes/EmbedService/EmbedHtmlFormatter.php passes the user-supplied class value directly to sprintf while constructing a figure element. A quote in the class value can terminate the class attribute and inject arbitrary HTML attributes or markup into the rendered page. A user able to edit a wiki page can store JavaScript that executes for visitors who render the affected content. This issue is fixed in version 4.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55691?

2 open source packages ship an affected version, including starcitizenwiki/embedvideo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizenwiki/embedvideo` | Packagist | All versions | 4.1.0 |
| `starcitizenwiki/embedvideo` | Packagist | All versions | 4.1.0 |

## How do I fix CVE-2026-55691?

Upgrade starcitizenwiki/embedvideo to 4.1.0 or later.

## Is CVE-2026-55691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55691 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55691 and fix it if it is affected.

What it is: CVE-2026-55691 is a high-severity cross-site scripting vulnerability in StarCitizenWiki mediawiki-extensions-EmbedVideo, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55691 exists.

Affected packages and fixed versions:
- starcitizenwiki/embedvideo (Packagist): affected all versions; fixed in 4.1.0
- starcitizenwiki/embedvideo (Packagist): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55691/ (Markdown: https://insights.sbomify.com/CVE-2026-55691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55691
- OSV: https://osv.dev/vulnerability/CVE-2026-55691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55691/
Summaries are generated and may contain mistakes; the official description above is the record.
