{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55695 exists.","fix":"No fix has been published for CVE-2026-55695 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-55695 is a critical code injection vulnerability in fearlessgeekmedia FearlessCMS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55695 and fix it if it is affected.\n\nWhat it is: CVE-2026-55695 is a critical code injection vulnerability in fearlessgeekmedia FearlessCMS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55695 exists.\n\nAffected product: fearlessgeekmedia FearlessCMS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55695/ (Markdown: https://insights.sbomify.com/CVE-2026-55695/index.md)","id":"CVE-2026-55695","markdown":"https://insights.sbomify.com/CVE-2026-55695/index.md","name":"CVE-2026-55695","record":{"aliases":["GHSA-56wm-3q3v-m93m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"FearlessCMS","requires_auth":"high_privilege","summary":"An authenticated administrator can achieve remote code execution by specifying a malicious Git repository URL in the system updater, allowing arbitrary PHP execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"FearlessCMS is a flat-file content management system centered on simplicity and open source. In 0.1.2b and earlier, an authenticated administrator can set an arbitrary Git repository URL through admin/updater-handler.php and trigger perform_update, which passes the URL to update.sh. The updater clones the repository and replaces the live plugins/, admin/, and includes/ directories without verifying the repository's identity, signatures, or contents. Because router.php permits existing PHP files under plugins to be executed by the PHP development server, attacker-supplied update content can execute arbitrary PHP with the web server process's privileges and persist as a backdoor. This issue is fixed in version 0.1.3b.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"FearlessCMS: Remote Code Execution via Unvalidated Update Repository URL in System Updater","id":"CVE-2026-55695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"PrivateBin has stored Cross-Side-Scripting (XSS) vulnerability in attachment download link via dangerous MIME types with required user-interaction","id":"CVE-2026-55696"},"packages":[],"prev":{"headline":"Snipe-IT: Chained Information Disclosure and IDOR Leads to Full EULA File Takeover","id":"CVE-2026-55694"},"products":["FearlessCMS"],"published":"2026-10-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["fearlessgeekmedia"]},"summary":"An authenticated administrator can achieve remote code execution by specifying a malicious Git repository URL in the system updater, allowing arbitrary PHP execution.","url":"https://insights.sbomify.com/CVE-2026-55695/"}