# CVE-2026-55695: FearlessCMS: Remote Code Execution via Unvalidated Update Repository URL in System Updater

> An authenticated administrator can achieve remote code execution by specifying a malicious Git repository URL in the system updater, allowing arbitrary PHP execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-56wm-3q3v-m93m

## What is CVE-2026-55695?

CVE-2026-55695 is a critical code injection vulnerability in fearlessgeekmedia FearlessCMS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

FearlessCMS is a flat-file content management system centered on simplicity and open source. In 0.1.2b and earlier, an authenticated administrator can set an arbitrary Git repository URL through admin/updater-handler.php and trigger perform_update, which passes the URL to update.sh. The updater clones the repository and replaces the live plugins/, admin/, and includes/ directories without verifying the repository's identity, signatures, or contents. Because router.php permits existing PHP files under plugins to be executed by the PHP development server, attacker-supplied update content can execute arbitrary PHP with the web server process's privileges and persist as a backdoor. This issue is fixed in version 0.1.3b.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55695?


## How do I fix CVE-2026-55695?

No fix has been published for CVE-2026-55695 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55695 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55695 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55695 and fix it if it is affected.

What it is: CVE-2026-55695 is a critical code injection vulnerability in fearlessgeekmedia FearlessCMS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55695 exists.

Affected product: fearlessgeekmedia FearlessCMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55695/ (Markdown: https://insights.sbomify.com/CVE-2026-55695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55695
- OSV: https://osv.dev/vulnerability/CVE-2026-55695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55695/
Summaries are generated and may contain mistakes; the official description above is the record.
