CVE-2026-55697 pnpm: Repository-controlled configDependencies can select a pacquet native install engine
A malicious repository can force pnpm to execute an attacker-controlled binary by declaring it as a config dependency, leading to arbitrary code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55697?
CVE-2026-55697 is a high-severity code injection vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.
Which versions are affected by CVE-2026-55697?
4 open source packages ship an affected version, including pnpm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pnpm npm | All versions | 10.34.2 |
pnpm npm | All versions | 10.34.2 |
pnpm npm | From 11.0.0 | 11.5.3 |
pnpm npm | From 11.0.0 | 11.5.3 |
Products include Pnpm Pnpm.
How do I fix CVE-2026-55697?
Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55697 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55697 exists.
Other vulnerabilities in pnpm
- CVE-2026-50016 pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement
- CVE-2026-55698 pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes
- CVE-2025-69264 pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"
- CVE-2022-26183 Untrusted Search Path in PNPM
- CVE-2026-59195 pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config
Sources
Also known as ECHO-cb6d-0144-08e3, GHSA-gj8w-mvpf-x27x, MINI-vpj5-pmj9-x333, ROOT-APP-NPM-CVE-2026-55697.