{"answers":{"affected":"4 open source packages ship an affected version, including pnpm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55697 exists.","fix":"Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.","what":"CVE-2026-55697 is a high-severity code injection vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55697 and fix it if it is affected.\n\nWhat it is: CVE-2026-55697 is a high-severity code injection vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55697 exists.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected all versions; fixed in 10.34.2\n- pnpm (npm): affected all versions; fixed in 10.34.2\n- pnpm (npm): affected from 11.0.0; fixed in 11.5.3\n- pnpm (npm): affected from 11.0.0; fixed in 11.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55697/ (Markdown: https://insights.sbomify.com/CVE-2026-55697/index.md)","id":"CVE-2026-55697","markdown":"https://insights.sbomify.com/CVE-2026-55697/index.md","name":"CVE-2026-55697","record":{"aliases":["ECHO-cb6d-0144-08e3","GHSA-gj8w-mvpf-x27x","MINI-vpj5-pmj9-x333","ROOT-APP-NPM-CVE-2026-55697"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"A malicious repository can force pnpm to execute an attacker-controlled binary by declaring it as a config dependency, leading to arbitrary code execution.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pnpm","vendor":"pnpm"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-494","name":"Download of Code Without Integrity Check"}],"description":"pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/\u003cplatform\u003e-\u003carch\u003e/pacquet binary from node_modules/.pnpm-config/\u003cpackageName\u003e and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pnpm: Repository-controlled configDependencies can select a pacquet native install engine","id":"CVE-2026-55697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes","id":"CVE-2026-55698"},"packages":[{"ecosystem":"npm","fixed":["10.34.2"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-gj8w-mvpf-x27x"},{"ecosystem":"npm","fixed":["10.34.2"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-gj8w-mvpf-x27x"},{"ecosystem":"npm","fixed":["11.5.3"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-gj8w-mvpf-x27x"},{"ecosystem":"npm","fixed":["11.5.3"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-gj8w-mvpf-x27x"}],"prev":{"headline":"PrivateBin has stored Cross-Side-Scripting (XSS) vulnerability in attachment download link via dangerous MIME types with required user-interaction","id":"CVE-2026-55696"},"products":["pnpm"],"published":"2026-06-25","related":[{"cvss_score":8.8,"headline":"pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement","id":"CVE-2026-50016","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes","id":"CVE-2026-55698","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm v10+ Bypass \"Dependency lifecycle scripts execution disabled by default\"","id":"CVE-2025-69264","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":8.8,"headline":"Untrusted Search Path in PNPM","id":"CVE-2022-26183","kev_date_added":null,"published":"2022-03-21"},{"cvss_score":8.2,"headline":"pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config","id":"CVE-2026-59195","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":7.6,"headline":"pnpm vulnerable to Command Injection via environment variable substitution","id":"CVE-2025-69262","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":7.5,"headline":"pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle","id":"CVE-2026-55487","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-29","vendors":["pnpm"]},"summary":"A malicious repository can force pnpm to execute an attacker-controlled binary by declaring it as a config dependency, leading to arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2026-55697/"}