# CVE-2026-55697: pnpm: Repository-controlled configDependencies can select a pacquet native install engine

> A malicious repository can force pnpm to execute an attacker-controlled binary by declaring it as a config dependency, leading to arbitrary code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** ECHO-cb6d-0144-08e3, GHSA-gj8w-mvpf-x27x, MINI-vpj5-pmj9-x333, ROOT-APP-NPM-CVE-2026-55697

## What is CVE-2026-55697?

CVE-2026-55697 is a high-severity code injection vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-55697?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-55697?

Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.

## Is CVE-2026-55697 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55697 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55697 and fix it if it is affected.

What it is: CVE-2026-55697 is a high-severity code injection vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55697 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55697/ (Markdown: https://insights.sbomify.com/CVE-2026-55697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55697
- OSV: https://osv.dev/vulnerability/CVE-2026-55697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55697/
Summaries are generated and may contain mistakes; the official description above is the record.
