CVE-2026-55698 pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes
A malicious repository can commit lockfile metadata to bypass package resolution and execute arbitrary code during pnpm version switching.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55698?
CVE-2026-55698 is a high-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can persist package-manager bootstrap metadata in the first YAML document of pnpm-lock.yaml. Before the patch, direct pnpm execution trusted an already resolved packageManagerDependencies entry when the committed env lockfile contained matching pnpm and @pnpm/exe versions. A malicious repository could therefore commit package-manager lockfile package records and snapshots that bypassed fresh package-manager resolution, then cause pnpm to install and execute bytes selected by that committed lockfile state during automatic version switching. This vulnerability is fixed in 10.34.2 and 11.5.3.
Which versions are affected by CVE-2026-55698?
4 open source packages ship an affected version, including pnpm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pnpm npm | All versions | 10.34.2 |
pnpm npm | All versions | 10.34.2 |
pnpm npm | From 11.0.0 | 11.5.3 |
pnpm npm | From 11.0.0 | 11.5.3 |
Products include Pnpm Pnpm.
How do I fix CVE-2026-55698?
Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.
Is CVE-2026-55698 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55698 exists.
Other vulnerabilities in pnpm
- CVE-2026-50016 pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement
- CVE-2025-69264 pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"
- CVE-2022-26183 Untrusted Search Path in PNPM
- CVE-2026-59195 pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config
- CVE-2025-69262 pnpm vulnerable to Command Injection via environment variable substitution
Sources
Also known as GHSA-w466-c33r-3gjp, MINI-4c4q-w4x3-cwx8, ROOT-APP-NPM-CVE-2026-55698.