# CVE-2026-55733: Atom-table exhaustion denial of service in Guardian permissions AtomEncoding via unbounded atom creation

> Attacker can crash the BEAM node by exhausting the atom table via unbounded atom creation in Guardian permissions, requiring non-default AtomEncoding configuration.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** EEF-CVE-2026-55733, GHSA-fjr5-7xrc-hmpj

## What is CVE-2026-55733?

CVE-2026-55733 is a medium-severity denial of service vulnerability in ueberauth guardian, published on 1 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling in ueberauth guardian allows denial of service via unbounded atom creation from attacker-controlled binary input.

Guardian.Permissions.AtomEncoding encodes permission scopes by passing arbitrary binaries to String.to_atom/1. When encode/3 in lib/guardian/permissions/atom_encoding.ex is called with a list, each binary entry is handled by the encode_value/3 binary clause, which calls String.to_atom(value) with no allow-list check. The perm_set argument (the application's small, finite set of legitimate permission names) is discarded, so any external string flows straight into atom creation. This encoder is selected with use Guardian.Permissions, encoding: Guardian.Permissions.AtomEncoding and reached through the imported encode/3 entry point.

String.to_atom/1 creates a brand-new atom for every previously unseen binary, atoms are never garbage collected, and the BEAM atom table is fixed at roughly 1,048,576 entries by default. An application that funnels attacker-influenced permission scopes (from a request body, a JWT claim, or other external input) into encode/3 therefore mints one permanent atom per distinct value. A modest stream of varied, unauthenticated input permanently consumes the atom table and crashes the BEAM node with system_limit, taking down every application running on it.

The default encoder is Guardian.Permissions.BitwiseEncoding, which is not affected.

This issue affects guardian: from 2.0.0 before 2.4.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-55733?

1 open source package ship an affected version, including guardian. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guardian` | Hex | From 2.0.0 | 2.4.1 |

Products: Ueberauth Guardian.

## How do I fix CVE-2026-55733?

Upgrade guardian to 2.4.1 or later.

## Is CVE-2026-55733 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55733 exists.

## Other vulnerabilities in ueberauth guardian

- [CVE-2026-55735](https://insights.sbomify.com/CVE-2026-55735/): Guardian.revoke/3 acts on unverified token claims, allowing forged-token session revocation (high 8.2)
- [CVE-2026-54894](https://insights.sbomify.com/CVE-2026-54894/): Atom-table exhaustion denial of service in Guardian via unbounded atom creation from binary keys (medium 6.9)
- [CVE-2026-55734](https://insights.sbomify.com/CVE-2026-55734/): guardian atom exhaustion in Guardian.Permissions.encode_permissions!/1 (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55733 and fix it if it is affected.

What it is: CVE-2026-55733 is a medium-severity denial of service vulnerability in ueberauth guardian, published on 1 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55733 exists.

Affected packages and fixed versions:
- guardian (Hex): affected from 2.0.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55733/ (Markdown: https://insights.sbomify.com/CVE-2026-55733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55733
- OSV: https://osv.dev/vulnerability/CVE-2026-55733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55733/
Summaries are generated and may contain mistakes; the official description above is the record.
